<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<link rel="stylesheet" href="css/lightbox.css" type="text/css"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Arcade: MAME v0.182 :: AEP Emulation Page - Emulation News :: Online seit dem 1. April 1998</title>
<meta name="KEYWORDS" content="emulation emulator emulators emu emulate video games Sega Nintendo Arcade Atari Computers consoles konsolen computer spiele emus emuz aep snes gameboy psx ps2 n64 gamecube n-gage bandai wonderswan 3do retro spiele games epsxe visualboy zsnes snes9x project64 gp32 snes genesis jaguar rss feed modeler zinc dolphin postnuke amiga commodore neo-geo neogeo xbox cxbx chankast chanka aepgb cvsbuilds 1964 pearpc nessie nocash mame32 mameplus neomame raine nebula hyperds gens gcube psp nds">
<meta name="DESCRIPTION" content="Emulation News, Emulator Download Database, Game and Hardware Reviews, Forum, Translations, Savestates, Weblinks, Pokemon, FAQs, SNES, C64, Commodore, Nintendo 64, Playstation, Game Boy, Dreamcast, Xbox, Wii, Arcade, Amiga, Atari, Sega">
<meta name="ROBOTS" content="INDEX,FOLLOW"><meta name="resource-type" content="document">
<meta http-equiv="expires" content="0">
<link rel="search" type="application/opensearchdescription+xml" href="/opensearch_desc.xml" title="AEP Emulation Page"><link rel="shortcut icon" href="/favicon.ico" type="image/x-icon"><link rel="icon" href="/favicon.ico" type="image/x-icon"><meta name="author" content="AEP Emulation Page - Emulation News">
<meta name="copyright" content="Copyright (c) 1998 - 2011 by AEP Emulation Page - Emulation News">
<meta name="revisit-after" content="1 days">
<meta name="distribution" content="Global">
<meta name="generator" content="PostNuke - http://postnuke.com\"><meta name="rating" content="General">
<meta http-equiv="Content-Script-Type" content="text/javascript"><link rel="alternate" type="application/x-opera-widgets" title="AEP Emulation News Ticker" href="http://widgets.opera.com/widgetize/Feed%20Reader/Advanced/?serve&amp;skin=skin10&amp;widgetname=AEP%20Emulation%20News%20Ticker&amp;url=http%3A%2F%2Fwww.aep-emu.de%2Frss_en.xml&amp;rel=myopera&amp;ref="><link rel="alternate" type="application/rss+xml" title="RSS" href="/rss_en.xml"><link rel='stylesheet' href='themes/Rhuknet2/style/style.css'><script src="/ckeditor/ckeditor.js" type="text/javascript"></script><script type="text/javascript" src="/javascript/socialshareprivacy/jquery.js"></script> 
  <script type="text/javascript" src="/javascript/socialshareprivacy/jquery.socialshareprivacy.min.js"></script>
  <script type="text/javascript">
    jQuery(document).ready(function($){
      if($('#socialshareprivacy').length > 0){
        $('#socialshareprivacy').socialSharePrivacy(); 
      }
    });
  </script>
<link rel="StyleSheet" href="modules/PNphpBB2/templates/PNTheme/styles/Rhuknet2.css" type="text/css">
</head><body>
<script type="text/javascript">
	jQuery(function($){
		if($('#socialshareprivacyAEP').length > 0){
			$('#socialshareprivacyAEP').socialSharePrivacy({"css_path":"\/css\/socialshareprivacy.css","services":{"facebook":{"status":"on","dummy_img":"\/images\/social\/dummy_facebook.png","perma_option":"on","action":"recommend"},"twitter":{"status":"on","dummy_img":"\/images\/social\/dummy_twitter.png","perma_option":"on"},"gplus":{"status":"on","dummy_img":"\/images\/social\/dummy_gplus.png","perma_option":"on","language":"de"}}});
		}
	});
</script>

<table cellpadding="5" cellspacing="0" width="99%" style="background-color:#9DB0B5;border : 1px solid #000000;"><tr><td colspan="3"><form method="post" action="modules.php?op=modload&amp;name=Search&amp;file=index"><table cellpadding="0" cellspacing="0" width="100%"  style="border : 1px solid #000000;"><tr><td bgcolor="#C8D0D4" valign="middle" rowspan="2"><a href="/"><img src="themes/Rhuknet2/images/titlebar.png" alt="Welcome to AEP Emulation Page - Emulation News" title="Welcome to AEP Emulation Page - Emulation News" width="500" height="81"></a></td>
<td bgcolor="#CED5D6" align="right"><img src="/themes/Rhuknet2/images/pixel.gif" alt="" width="1" height="44"></td><td bgcolor="#CED5D6" align="right" width="90%"><input type="text" name="q" size="15" style="margin:0"><input type="hidden" name="action" value="search"><input type="hidden" name="overview" value="1"><input type="hidden" name="stories_topics[]" value="0"><input type="hidden" name="stories_cat[]" value="0"><input type="hidden" name="active_downloads" value="1"><input type="hidden" name="active_sections" value="1"><input type="hidden" name="active_emus" value="1"><input type="hidden" name="active_forum" value="1"><input type="hidden" name="active_stories" value="1"><input type="submit" name="submit" value="Search"></td></tr><tr><td bgcolor="#9DB1AF" align="right"><img src="/themes/Rhuknet2/images/pixel.gif" alt="" width="1" height="37"></td><td bgcolor="#9DB1AF" align="right"><script type="text/javascript">

<!--   // Array ofmonth Names
var monthNames = new Array( "January","February","March","April","May","June","July","August","September","October","November","December");
var now = new Date();
var thisYear = now.getYear();
if(thisYear < 1900) {thisYear += 1900}; // corrections if Y2K display problem
document.write(now.getDate()+ ". " + monthNames[now.getMonth()] + " " + thisYear);
// -->

</script>&nbsp;&nbsp;&nbsp;<br>Hosting by: Uberspace.de&nbsp;&nbsp;&nbsp;</td></tr>
<tr><td bgcolor="#ffcc00" colspan="3" style="border-top : 1px solid #000000;border-bottom : 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td colspan="3" bgcolor="#B8C6C9"><div><span style="float: left; font-weight:bold;">&nbsp;&nbsp;<a href="user.php" style="color:#ff0000">Login/Create an account</a>
</span><span style="float: right"><a href="/" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Home</b></a> | <a href="user.php" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Account</b></a> | <a href="emus.html" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Emulatoren</b></a> | <a href="forum.html" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Forum</b></a> | <a href="PNphpBB2-file-activity.html" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Online Games</b></a> | <a href="Web_Links.html" onMouseOver="this.style.background='#ffcc00'" onMouseOut="this.style.background='#B8C6C9'" style="color:#000000"><b>Web Links</b></a>&nbsp;&nbsp;</span></div></td></tr></table></form>
</td></tr><tr valign="top"><td width="200">
<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Menu</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="/" title="Home / News">Home / News</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Topics.html" title="News Categories">News Categories</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Archive.html" title="News Archive">News Archiv</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Submit_News.html" title="Submit news">Submit news</a><br>
<br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="user.php" title="My Account">My Account</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Search.html" title="Search">Search</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="forum.html" title="Forums">Forums</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="PNphpBB2-file-activity.html" title="Online Games">Online Games</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Web_Links.html" title="Weblinks">Weblinks</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Reviews.html" title="Game Reviews">Game Reviews</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Downloads-req-viewdownload-cid-3.html" title="Translations">Translations</a><br>
<strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="http://aep-emu.spreadshirt.net/" title="Hier gehts zu unserem Online Shop"><img src="/images/aep_shop.png" alt="AEP Shop"></a><br></td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Downloads</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><div align="left"><form method="post" action="index.php"><fieldset style="border:0"><legend></legend>
<select class="mySelect" name="emuswitch" onChange="top.location.href=this.options[this.selectedIndex].value">
<option>- Emulator -</option>
<option value="Emus.html">- Overview -</option>
<option value="emus16.html">32x</option>
<option value="emus39.html">3DO</option>
<option value="emus5.html">A2600</option>
<option value="emus7.html">A5200</option>
<option value="emus8.html">A7800</option>
<option value="emus73.html">Acorn BBC</option>
<option value="emus24.html">Amiga</option>
<option value="emus71.html">Amstrad CPC</option>
<option value="emus60.html">AppleI</option>
<option value="emus61.html">AppleII</option>
<option value="emus69.html">Apple Mac</option>
<option value="emus13.html">Arcade Multi</option>
<option value="emus67.html">Arcade Single</option>
<option value="emus75.html">Atari 8-bit</option>
<option value="emus11.html">Atari ST</option>
<option value="emus9.html">Atari Jaguar</option>
<option value="emus73.html">BBC Micro</option>
<option value="emus62.html">C16/Plus4</option>
<option value="emus25.html">C64</option>
<option value="emus38.html">Coleco</option>
<option value="emus71.html">CPC</option>
<option value="emus41.html">Diverse</option>
<option value="emus20.html">Dreamcast</option>
<option value="emus2.html">Game Boy</option>
<option value="emus4.html">Game Boy Adv.</option>
<option value="emus3.html">Game Boy Color</option>
<option value="emus4.html">GBA</option>
<option value="emus3.html">GBC</option>
<option value="emus23.html">Gamecube</option>
<option value="emus18.html">Game Gear</option>
<option value="emus15.html">Genesis</option>
<option value="emus37.html">GP32</option>
<option value="emus40.html">Intellivision</option>
<option value="emus9.html">Jaguar</option>
<option value="emus45.html">Japanische</option>
<option value="emus12.html">Lynx</option>
<option value="emus69.html">Macintosh</option>
<option value="emus14.html">Master System</option>
<option value="emus74.html">MB Vectrex</option>
<option value="emus15.html">Mega Drive</option>
<option value="emus41.html">Misc</option>
<option value="emus42.html">MSX</option>
<option value="emus22.html">N64</option>
<option value="emus28.html">NeoGeo</option>
<option value="emus58.html">NeoGeo-CD</option>
<option value="emus68.html">NintendoDS</option>
<option value="emus29.html">NG Pocket</option>
<option value="emus10.html">NES</option>
<option value="emus57.html">PC</option>
<option value="emus30.html">PC-Engine</option>
<option value="emus26.html">Playstation</option>
<option value="emus27.html">Playstation 2</option>
<option value="emus62.html">Plus4</option>
<option value="emus70.html">PSP</option>
<option value="emus19.html">Saturn</option>
<option value="emus71.html">Schneider CPC</option>
<option value="emus17.html">Sega CD</option>
<option value="emus16.html">Sega 32x</option>
<option value="emus14.html">SMS</option>
<option value="emus1.html">SNES</option>
<option value="emus43.html">Spectrum</option>
<option value="emus11.html">ST / STE</option>
<option value="emus30.html">Turbografx16</option>
<option value="emus74.html">Vectrex</option>
<option value="emus21.html">Virtual Boy</option>
<option value="emus6.html">Wonderswan</option>
<option value="emus44.html">Xbox</option>
<option value="emus43.html">ZX Spectrum</option>
</select>

<select class="mySelect" name="systemswitch" onChange="top.location.href=this.options[this.selectedIndex].value">
<option>- Platform -</option>
<option value="Emus-file-emus_os-system-Dreamcast.html">Dreamcast</option>
<option value="Emus-file-emus_os-system-Dos.html">Dos</option>
<option value="Emus-file-emus_os-system-GBA.html">GBA</option>      
<option value="Emus-file-emus_os-system-GP2x.html">GP2x</option>   
<option value="Emus-file-emus_os-system-GP32.html">GP32</option>     
<option value="Emus-file-emus_os-system-Java.html">Java</option>     
<option value="Emus-file-emus_os-system-Linux.html">Linux</option>    
<option value="Emus-file-emus_os-system-MacOS.html">MacOS</option>    
<option value="Emus-file-emus_os-system-PalmOS.html">PalmOS</option>
<option value="Emus-file-emus_os-system-PocketPC.html">PocketPC</option>
<option value="Emus-file-emus_os-system-PSP.html">PSP</option>   
<option value="Emus-file-emus_os-system-PSX.html">PSX</option>      
<option value="Emus-file-emus_os-system-PS2.html">PS2</option>      
<option value="Emus-file-emus_os-system-Symbian.html">Symbian</option>  
<option value="Emus-file-emus_os-system-Windows.html">Windows</option>
<option value="Emus-file-xbox.html">X-Box</option>
</select>

<select class="mySelect" name="pluginsswitch" onChange="top.location.href=this.options[this.selectedIndex].value">
<option>- Plug-Ins -</option>
<option value="emus64.html">Nintendo 64</option>
<option value="emus59.html">Playstation 1</option>
<option value="emus65.html">Playstation 2</option>      
</select>

<select class="mySelect" name="downloadswitch" onChange="top.location.href=this.options[this.selectedIndex].value">
<option>- More Downloads -</option>
<option value="emus72.html">Frontends</option>
<option value="Downloads-req-viewdownload-cid-11.html">Legal Games</option>
<option value="Downloads-req-viewsdownload-sid-27.html">ROM-Hacks</option>      
<option value="Downloads-req-viewdownload-cid-8.html">Save-States</option>       
<option value="Downloads-req-viewdownload-cid-10.html">Tech-Docs</option>      
<option value="Emus-tools.html">Tools / Renamer</option>      
<option value="Downloads-req-viewdownload-cid-3.html">Translations</option>
<option value="snapshots.html">Snapshots</option>
</select></fieldset>
</form>
<br> 
<strong><big>&middot;</big></strong>&nbsp;<a href="http://www.pdroms.de/" target="_blank" title="PDRoms">ROMs (PDRoms)</a>
</div></td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Social Links</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><div id="socialshareprivacyAEP"></div>
</td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Select language</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><div align="center" class="pn-normal">Select interface language:<br><br><a href="/PNphpBB2-file-viewtopic-t-21790.html?newlang=eng"><img src="images/flags/flag-eng.png" alt="English" title="English" hspace="3" vspace="3" width="24" height="24"></a><a href="/PNphpBB2-file-viewtopic-t-21790.html?newlang=deu"><img src="images/flags/flag-deu.png" alt="German" title="German" hspace="3" vspace="3" width="24" height="24"></a></div></td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Forum</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><table align="center" width="98%" cellpadding="0" cellspacing="0" border="0"><tr><td colspan="10" align="center" valign="top"><span class="pn-normal"><strong>MEMBERS ONLINE</strong></span></td></tr><tr><td align="center">Currently no members online.</td></tr><tr><td><table width="98%" align="center" border="1" cellpadding="2" cellspacing="1"><tr><td align="center"><img src="./modules/PNphpBB2/pnimages/info.png" alt=""><br>You are an anonymous user. You can register for free by clicking <a href="user.php?op=check_age&amp;module=NS-NewUser"><b>here</b></a></td></tr></table></td></tr><tr><td align="center"><form action="user.php" method="post"><table width="98%" align="center" border="0" cellpadding="2" cellspacing="1"><tr><td align="center"><b>Username</b></td></tr><tr><td align="center"><input type="text" name="uname" size="14" maxlength="25"></td></tr><tr><td align="center"><b>Password</b></td></tr><tr><td align="center"><input type="password" name="pass" size="14" maxlength="20"></td></tr><tr><td align="center"><input type="checkbox" value="1" name="rememberme">&nbsp;Remember me</td></tr><tr><td align="center"><input type="submit" value="Login"><input type="hidden" name="module" value="NS-User"><input type="hidden" name="op" value="login"><input type="hidden" name="url" value=""></td></tr></table></form></td></tr></table></td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Infos</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px"><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections2.html" title="Hardware-Museum, mit vielen Infos zu Konsolen und Computern">Museum</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections8.html" title="Interessante Emulator Vergleiche und weitere Themen">Infocenter</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections-article31-page1.html" title="Wer sind wir, wer macht was?">Das AEP Team</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="index.php?name=PNphpBB2&amp;file=memberlist" title="AEP Mitgliederliste">Member Liste</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Top_List.html" title="Die Top 25 Liste von AEP.">Top 25 Liste</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections-article22-page1.html" title="Lame Mails - was zum lachen.">Lame Mails</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections-article61-page1.html" title="Liste mit Fachbegriffen und Abkürzungen">Glossar</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="FAQ.html" title="Frequently Asked Questions">FAQ</a><br><strong><big>&middot;</big></strong>&nbsp;<a class="pn-normal" href="Sections-req-viewarticle-artid-98.html" title="Impressum / Kontakt">Impressum</a><br></td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>Funny Quotes</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px">
<br><i>Mein zuletzt gekauftes Spiel? Ich glaub das war Pong, danach kam ja nichts gescheites mehr! :D</i><br><br>-- Bloby (AEP-Forum)</td>
</tr>
</table>
<br>


<table cellpadding="0" cellspacing="0" width="200" style="border: 1px solid #000000;">
<tr><td bgcolor="#ffcc00" style="border-bottom: 1px solid #000000;"><img src="themes/Rhuknet2/images/dots.gif" height="5" width="13" alt=""></td></tr>
<tr><td bgcolor="#B8C6C9" align="center" height="20" style="font-weight:bold;font-size:13px;color:#000000;">
<b>News-Export</b>
</td></tr>
<tr><td bgcolor="#000000"><img src="themes/Rhuknet2/images/pixel.gif" width="100%" height="1" alt=""></td></tr>
<tr>
<td bgcolor="#C8D0D4" style="padding:4px">Holt Euch unsere News auf Eure Seite: <br>
<strong><big>&middot;</big></strong>&nbsp;<a href="/Sections-article83-page1.html" title="Newsfeed (XML-RSS)">RSS Newsfeed How-to</a>
<br><strong><big>&middot;</big></strong>&nbsp;<a href="http://www.twitter.com/AEPEmu"><img src="/images/twitter-a.png" width="61" height="23" alt="Follow AEPEmu on Twitter"></a><br><strong><big>&middot;</big></strong>&nbsp;<a href="/rss_en.xml" target="_blank" title="RSS News-syndication English"><img src="images/powered/badge_aep_rss_en.png" alt="RSS News-syndication English" width="80" height="15"></a>
<br><strong><big>&middot;</big></strong>&nbsp;<a href="/rss_de.xml" target="_blank" title="RSS News-syndication Deutsch"><img src="images/powered/badge_aep_rss_de.png" alt="RSS News-syndication Deutsch" width="80" height="15"></a>
<br><strong><big>&middot;</big></strong>&nbsp;<a href="/Sections-article84-page1.html" title="News-Banner (JPG)"><img src="images/powered/badge_aep_banner.png" alt="News-Banner (JPG)" width="80" height="15"></a></td>
</tr>
</table>
<br>


<td width="100%">


<a name="top" id="top"></a>


<table class="bodyline" width="100%" cellspacing="0" cellpadding="0" border="0">
  <tr>
    <td align="center" valign="top">
      <table class="navbar" width="100%" cellspacing="1" cellpadding="2" border="0">
        <tr align="center">
          <td>
            <a href="index.php?name=PNphpBB2&amp;file=faq&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img class="inlineimg" src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_faq.gif" width="13" height="13" border="0" alt="FAQ" title="FAQ"> FAQ</a>&nbsp; &#8226;&nbsp;
            <a href="index.php?name=PNphpBB2&amp;file=search&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img class="inlineimg" src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_search.gif" width="13" height="13" border="0" alt="Search" title="Search"> Search</a>&nbsp; &#8226;&nbsp;
            <a href="user.php"><img class="inlineimg" src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_register.gif" width="13" height="13" border="0" alt="Register" title="Register"> Register</a>&nbsp; &#8226;&nbsp;
            <a href="index.php?name=PNphpBB2&amp;file=privmsg&amp;folder=inbox&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img class="inlineimg" src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_message.gif" width="13" height="13" border="0" alt="Log in to check your private messages" title="Log in to check your private messages"> Log in to check your private messages</a>
          </td>
        </tr>
        <tr align="center">
          <td>
            <a href="index.php?name=PNphpBB2&amp;file=login&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img class="inlineimg" src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_login.gif" width="13" height="13" border="0" alt="Log in" title="Log in"> Log in</a>
          </td>
        </tr>
               <tr>
                  <td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;
                     <a href="index.php?name=PNphpBB2&amp;file=activity&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="mainmenu"><img src="./modules/PNphpBB2/templates/PNTheme/images/icon_mini_activity.gif" width="12" height="13" border="0" alt="Arcade / Games" hspace="3">Arcade / Games</a>&nbsp; &nbsp;</span>
                  </td>
               </tr>
      </table>
	      <br clear="all">

			<table width="100%" border="0" cellspacing="0" cellpadding="5">
				<tr>
					<td>


<table width="100%" border="0" cellspacing="0" cellpadding="2">
  <tr>
    <td class="nav" align="left" valign="top">
      <a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;start=0&amp;postdays=0&amp;postorder=asc&amp;highlight=&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><span class="maintitle">Arcade: MAME v0.182</span></a>
      <br>
    </td>
    <!-- <td class="gensmall" align="right" valign="bottom"><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=next&amp;sid=192a599b7d6186efa01db38b4ff0cab7">View next topic</a><br>
<a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=previous&amp;sid=192a599b7d6186efa01db38b4ff0cab7">View previous topic</a><br>
<a href="index.php?name=PNphpBB2&amp;file=printview&amp;t=21790&amp;start=0&amp;sid=192a599b7d6186efa01db38b4ff0cab7" target="_blank" title="Printable version">Printable version</a><br>
<br>
<strong></strong><br>
</td> -->
  </tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr>
    <td class="nav" valign="top" width="100%">
      <a href="index.php?name=PNphpBB2&amp;file=index&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">AEP Emulation Page - Emulation News Forum Index</a>&nbsp;&raquo;&nbsp;<a href="index.php?name=PNphpBB2&amp;file=index&amp;c=3&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">Emu News</a>&nbsp;&raquo;&nbsp;<a href="index.php?name=PNphpBB2&amp;file=viewforum&amp;f=8&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">News</a>
    </td>
    <td align="right"></td>
  </tr>
  <tr>
    <td align="left" nowrap="nowrap">
      <a href="index.php?name=PNphpBB2&amp;file=posting&amp;mode=newtopic&amp;f=8&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/post.gif" width="82" height="25" alt="Post new topic" title="Post new topic"></a>&nbsp;&nbsp;&nbsp;<a href="index.php?name=PNphpBB2&amp;file=posting&amp;mode=reply&amp;t=21790&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/reply.gif" width="82" height="25" alt="Reply to topic" title="Reply to topic"></a>
    </td>
    <td nowrap="nowrap">
      <table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=previous&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_previous.gif" width="15" height="25" alt="View previous topic" title="View previous topic" border="0"></a></td>
<td></td>
<td><a href="index.php?name=PNphpBB2&amp;file=printview&amp;t=21790&amp;start=0&amp;sid=192a599b7d6186efa01db38b4ff0cab7" target="_blank"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_print.gif" width="24" height="25" border="0" alt="Printable version" title="Printable version"></a></td>
<td></td>
<td><a href="index.php?name=PNphpBB2&amp;file=privmsg&amp;folder=inbox&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/pm_no_new.gif" width="24" height="25" border="0" alt="Log in to check your private messages" title="Log in to check your private messages"></a></td>
<td><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=next&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_next.gif" width="14" height="25" alt="View next topic" title="View next topic" border="0"></a></td>
</tr>
</table>


    </td>
  </tr>
</table>

<table class="forumline" width="100%" cellspacing="1" border="0">
  
  <tr>
    <th class="th" width="20%">Author</th>
    <th class="th" width="80%">Message</th>
  </tr>
  <tr>
    <td class="row1">
      <table width="100%" border="0" cellpadding="3" cellspacing="0">
        <tr>
          <td valign="middle">
            <span class="name"><a name="98124"></a><strong>Björn</strong></span><img src="modules/PNphpBB2/templates/PNTheme/images/user_offline.gif" width="16" height="16" alt="Offline" title="Offline" hspace="3" align="top">
          </td>
        </tr>
      </table>
    </td>
    <td class="row1">
      <table width="100%" border="0" cellpadding="3" cellspacing="0">
        <tr>
					<td width="100%" class="postdetails">
            <span style="float:left;"><b>Post subject:</b> Arcade: MAME v0.182&nbsp;</span>
            <span style="float:right;"><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;p=98124&amp;sid=192a599b7d6186efa01db38b4ff0cab7#98124"><img src="modules/PNphpBB2/templates/PNTheme/images/icon_minipost.gif" width="12" height="9" alt="Post" title="Post"></a><b>Posted:</b> Jan 27, 2017 - 09:37 PM</span>
          </td>
				</tr>
      </table>
    </td>
  </tr>
  <tr>
    <td valign="top" class="row1" rowspan="2">
      <table width="100%" border="0" cellpadding="5" cellspacing="0">
        <tr>
          <td>
            <span class="postdetails">Retrokenner<br>
            <img src="modules/PNphpBB2/images/avatars/upload/7176189544439449ee281f.gif" alt=""></span><br><br>
            Joined: Sep 30, 2004<br>
            Posts: 351<br>
	    <br>
            Location: MS und KR<br><br>Highscores in 01/2017<br><br>
            Status: Offline
          </td>
        </tr>
      </table>
    </td>
    <td class="row1">
      <table width="100%" cellpadding="5" cellspacing="0">
        <tr>
          <td valign="top" class="postbody">Eine neue Version von <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> wurde veröffentlicht.
<br>

<br>
A new version of the <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> emulator has been published.
<br>

<br>
As we approach the 20th anniversary of the first <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> release, we’ve got a really exciting update for you. There’s so much awesome stuff in this month’s release that there’s no way we can possibly cover it all here. <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> is a team effort, and we’d like to thank everyone who’s contributed towards making this release as awesome as we think it is. One very exciting addition is support for another version of the East German Poly-Play system, with German and Czech ROM sets providing ten games, six of which are new. Protection on Future Flash/Laser Base has finally been emulated, so you can take a look at Hoei’s take on Missile Command. A dump of the <a href="http://caps0ff.blogspot.com/2016/12/taking-down-45-tatakae-big-fighter.html" target="_blank" class="postlink">damaged microcontroller (MCU)</a> from Tatakae! Big Fighter makes this title and Sky Robo finally playable. Another eagerly awaited addition is the Hot-B prototype Hangzo.Serial ports have been hooked up on Race Drivin’ allowing you to link two <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> instances over TCP, reproducing the multi-player experience with linked cabinets. To do this, use a null modem slot device and configure it for 38,400 Baud, 8 data bits, even parity, and 1 stop bit. It would also be possible to connect a <a href="http://www.aep-emu.de/Web_Links-req-visit-lid-133.html" target="_blank" class="postlink">MAME</a> instance to a real board set by forwarding the connection to a serial port on the host system.We’ve received a contributed PortAudio output module and integrated it in this release. This provides a cross-platform low latency audio output solution. Performance should be similar to Steinberg ASIO on Windows 7 or later without the licensing issues, and better than <a href="http://www.libsdl.org/" target="_blank" class="postlink">SDL</a> audio on Linux. It can be enabled by setting the sound parameter to portaudio on the command line or in an ini file. Of course, all the other audio output modules are still supported, so if you're happy with your current setup you don’t have to change anything.Although we haven’t added a huge number of new microcontroller (MCU) dumps in this release, substantial work has gone into improving systems where we already have dumps but the emulation is lacking. MCU emulation was added to Puzznic, Joshi Volleyball and Gladiator. For Puzznic, this places player data at the correct location in RAM and supplies the game with a pseudo-random number sequence rather than a stream of zeros. Joshi Volleyball now behaves better in service mode, allowing coins and inputs to be tested. Gladiator now honours the coinage DIP switches. The MC68705 core has had a complete overhaul, and all drivers using it have been reviewed. This fixes lots of subtle issues: for example Change Lanes will now skip the full memory tests if configured to ignore them in DIP switches, timings have improved in Arkanoid, and the Apple II mouse card is slightly improved. We now emulate the ’705 family well enough to support stand-alone MCU programmer boards.Other improvements include working sound in Pole Position bootlegs, improved video in Winning Run, preliminary banked 256 colour mode for the NEC PC-9821, kana input on the Sharp X1, a VME bus system with preliminary support for the miniFORCE 2P21 chassis, additional Aristocrat Mark 5 peripheral emulation allowing non-US games to boot, Corvus hard disks for the DEC Rainbow 100, preliminary work on Atari Stunt Cycle (displays the playfield), fixes for the Aussie Byte and Otrona Attaché, and support for octal and binary numbers in debugger expressions.For more detail on what’s changed, check out the <a href="http://mamedev.org/releases/whatsnew_0182.txt" target="_blank" class="postlink">whatsnew.txt file</a>, or grab the source or Windows binaries from <a href="http://mamedev.org/release.html" target="_blank" class="postlink">the download page</a> straight away. 
<br>

<br>
<div class="quotetitle"><b>Quote:</b></div><div class="quote">0.182
<br>
-----
<br>

<br>

<br>
MAMETesters Bugs Fixed
<br>
----------------------
<br>
- 04907: [Flip Screen/Cocktail] (combatsc.cpp) combatsc, combatscj, combatsct, bootcamp: Score line is not flipped with screen
<br>
  (Angelo Salese)
<br>
- 05313: [DIP/Input] (namcos21.cpp) winrun, winrun91, winrungp,driveyes: Misplaced Controls (Angelo Salese)
<br>
- 05392: [Documentation] (royalmah.cpp) janputer: info about &quot;New Double Bet Mahjong&quot; (Angelo Salese)
<br>
- 06216: [Sound] (ptcsol.cpp) sol20: Audio support (Robbbert)
<br>
- 06422: [Graphics] (rohga.cpp) wolffang: (Japanese Wolf Fang Only) Text at attract mode is cropped (David Haywood)
<br>
- 06460: [Sound] (stlforce.cpp) stlforce: OKI6295 speed is too slow (system11)
<br>
- 06461: [DIP/Input] (pacman.cpp) eeekk: 2P Start Button map is missing (Tafoid)
<br>
- 06464: [Interface] Every system with softlists using the &quot;requirement&quot; sharedfeat: Software list items with the &quot;requirement&quot;
<br>
  sharedfeat don't work (AJR)
<br>
- 06467: [Gameplay] (hh_tms1k.cpp) elecdet: Every suspect gives the same alibi. (hap)
<br>
- 06468: [DIP/Input] (gladiatr.cpp) gladiatr ogonsiro gcastle: Coinage DIP switches have no effect in sets using MCU simulation
<br>
  (Vas Crabb)
<br>

<br>

<br>
New working machines
<br>
--------------------
<br>
Conic Electronic Basketball [hap, Sean Riddle]
<br>
Conic Multisport/Tandy Sports Arena [hap, Sean Riddle]
<br>
Enma Daio (Japan) [rtw, Ryan Holtz, Dullaron, Firebricks, redk9258, W. Perez, Anonymous from Switzerland, Darksoft, Smitdogg,
<br>
  David Haywood, ShouTime, Andy Welburn, The Dumping Union]
<br>
Gakken Galaxy Invader 1000/Tandy Cosmic 1000 Fire Away [hap, Sean Riddle, Kevin Horton]
<br>
Hangzo (Japan, prototype)
<br>
  [ShouTime, Smitdogg, David Haywood, Imhotep, Ryan Holtz, hap, Zhivko Dimitrov, spogghi, ANY, Arjen Hoekman, Arcade Addict, krick,
<br>
  Dullaron, Eddie, f205v, rtw, Rod_Wod, Fabien Marsaud, InsertMoreCoins, Jan Stuhler, trap15, Macaw, Team Japump, Brandon Munger,
<br>
  Juan Manuel Gutierrez, abelardator2, Jordi Bosch Creus, haynor666, Nestor Acebo Jimenez, Carl Perry, Jeremy McElroy,
<br>
  Steven Boswell, JJaVMeTaL, Steven LeMaire, Matthew Shultz, Mark Riley has no toaster, Carlos Gutierrez, Bjorn Stahl,
<br>
  Aldo Vittorio De Luca, Bruno Celsi, Philip Zumbrun, cornishdavey, Stefano De Dionigi, motoschifo, Mamesick, Daniel Hitchcock,
<br>
  Patrick Wheeler, bisus, desodeso, Swos, Don Zaucker, Tox Nox Fox, Zak0077, giuppo, Moket, Frankie, robindan77, biasini, Dr_Zero,
<br>
  motoschifo, Mameremember, John Wilke, Sean Sutton, Renato Mucciarelli, Berlioux Julien, Lior Aouate, The Dumping Union]
<br>
Mattel Dalla$ (J.R. handheld) [hap, Sean Riddle]
<br>
Mattel Thoroughbred Horse Race Analyzer [hap, Sean Riddle]
<br>
Motorola MC68705P5 Programmer [Vas Crabb]
<br>
Poly-Play (ZRE-PP) [SailorSat]
<br>
Tiger 7 in 1 Sports Stadium [hap, Sean Riddle]
<br>

<br>

<br>
New working clones
<br>
------------------
<br>
Atari PC1 [rfka01]
<br>
Dynamite Duke (Japan, 25JUL89) [Corrado Tomaselli, The Dumping Union]
<br>
Fidelity Elite Avant Garde (model 6114-2/3/4, set 2) [Berger]
<br>
Fighting Fantasy (Japan revision ?) [Hammy, The Dumping Union]
<br>
King of the Monsters 2 - The Next Thing (older) [NeoSD]
<br>
Motorola MC68705P3 Programmer [Vas Crabb]
<br>
Motorola MC68705R3 Programmer [Vas Crabb]
<br>
Motorola MC68705U3 Programmer [Vas Crabb]
<br>
Poly-Play (ZRE-PP - Czech) [SailorSat]
<br>
Research Machines RM-380Z, COS 3.4D [zx70]
<br>
Research Machines RM-380Z, COS 3.4E [zx70]
<br>
Robo Army (NGM-032 ~ NGH-032)  [JacKc]
<br>
Saulabi Spirits / Jin Saulabi Tu Hon (Korean release of Samurai Shodown II, set 2)  [JacKc]
<br>
Skull Fang (Asia) [coolmod, The Dumping Union]
<br>
Star Fighter (bootleg of Astro Fighter) [f205v]
<br>

<br>

<br>
Machines promoted to working
<br>
----------------------------
<br>
Novag Diablo 68000 [hap]
<br>
Novag Super Expert (several versions) [hap, Berger]
<br>
Novag Super Forte (several versions) [hap, Berger]
<br>
Future Flash [Morten Shearman Kirkegaard, Samuel Neves, Peter Wilhelmsen, Tomasz Slanina]
<br>
Force SYS68K/CPU-20 [Joakim Larsson Edstrom]
<br>
Otrona Attache [zx70]
<br>
Robo Army (NGM-032 ~ NGH-032)  [JacKc]
<br>
Sky Robo [CAPS0ff, Angelo Salese]
<br>

<br>

<br>
Clones promoted to working
<br>
--------------------------
<br>
Laser Base (set 1) [Morten Shearman Kirkegaard, Samuel Neves, Peter Wilhelmsen, Tomasz Slanina]
<br>
Laser Base (set 2) [Morten Shearman Kirkegaard, Samuel Neves, Peter Wilhelmsen, Tomasz Slanina]
<br>
Tatakae! Big Fighter (Japan) [CAPS0ff, Angelo Salese]
<br>

<br>

<br>
New machines marked as NOT_WORKING
<br>
----------------------------------
<br>
Ator (Videodens) [AJR, Gonzalo]
<br>
Bloody Roller (Playbar) [AJR, Akiles500]
<br>
Compugraphic MCS PowerView 10 [Carl, Al Kossow]
<br>
Cobra (Playbar) [AJR, Iso Tropia]
<br>
Happy Fish (V2 PCB, 302-in-1) [The Dumping Union]
<br>
LINK RM-480Z (set 1) [Robbbert]
<br>
LINK RM-480Z (set 2) [Robbbert]
<br>
Mega Bonus Star II (Euro, Millennium Edition) [Roberto Fresca, Team Europe]
<br>
miniFORCE VME Chassis [Joakim Larsson Edstrom]
<br>
Slalom Code 0.3 (Stargame) [AJR, Akiles500]
<br>

<br>

<br>
New clones marked as NOT_WORKING
<br>
--------------------------------
<br>
Eight Ball Champ (Spain, Z-Pinball hardware) [AJR, Iso Tropia]
<br>
MotorDome (German) [PinMAME]
<br>
Star Horse Progress (backup data) [any, Lord-Nightmare, MetalliC, rtw, ShouTime]
<br>
Star Horse Progress (live, Rev A) [any, Lord-Nightmare, MetalliC, rtw, ShouTime]
<br>
Star Horse Progress (main screens, Rev B) [any, Lord-Nightmare, MetalliC, rtw, ShouTime]
<br>
Star Horse Progress (sound &amp; backup, Rev A) [any, Lord-Nightmare, MetalliC, rtw, ShouTime]
<br>
World Kicks (Japan, WK1 Ver.A) [rtw]
<br>

<br>

<br>
New working software list additions
<br>
-----------------------------------
<br>
-archimedes.xml: over 30 games (some protected), and many apps [Nigel Barnes]
<br>
-atom_cass.xml: Backgammon, Cylon Attack, Early Warning, Minefield, Tangled [Nigel Barnes]
<br>
-atom_flop.xml: Galaxians (Aardvark) [Nigel Barnes]
<br>
-ibmpcjr_cart.xml: Fraction Fever [Anna Wu, Justin Kerk]
<br>
-t1000.xml:
<br>
 MS-DOS (Verson 3.20, Tandy version 03.20.21) (Tandy 1000 TX), DeskMate (Tandy 1000), DeskMate II (Tandy 3000), Personal DeskMate,
<br>
 Personal DeskMate 2 (Tandy 1000 HX), Personal DeskMate 2 (Tandy 1000 HX, Alt), Personal DeskMate 2 (Tandy 1000 TX),
<br>
 King's Quest (Tandy), Transylvania (Tandy) [Justin Kerk]
<br>
-x1_cass.xml:
<br>
 198X-nen, 3D Golf Simulation, Fushigi no Kuni no Alice, Ankokujou, Danchizuma no Yuuwaku, Intelli Janshi - Yonin Mahjong,
<br>
 Ultra Story, Xanadu [r09]
<br>

<br>

<br>
Source Changes
<br>
--------------
<br>
-Rewrote Namco C148 (interrupt controller) and C193 (SCI) devices. [Angelo Salese]
<br>
 * Fixed POS interrupt generation for Winning Run/Winning Run '91/Winning Run Suzuka GP.
<br>
 * Fixed trail tachometer drawing in Winning Run.
<br>

<br>
-deco32.cpp: Added preliminary global volume control for nslasher and fghthist. [Angelo Salese]
<br>

<br>
-Wrote a device core for the Namco 6-speed gearbox. [Angelo Salese]
<br>
 * Used by Driver's Eyes, Ridge Racer DX and Ace Driver.
<br>

<br>
-Added preliminary banked 256 color mode to PC-9821. [Angelo Salese]
<br>

<br>
-naomi.cpp: Added inputs for Mars TV. [Angelo Salese]
<br>

<br>
-Dumped i8751 MCU for Sky Robo / Takatae Big Fighter and added basic hookup to make it work. [CAPS0ff, Angelo Salese]
<br>

<br>
-punkywil: Added a ridiculously incomplete dump of the CPU ROM. [AJR, Akiles500]
<br>

<br>
-Z80 daisy chain improvements: [AJR]
<br>
 * Use the standard vector for an external IRQ, rather than a bogus one from the last device in the chain.
<br>
 * Enabled Z80 daisy chain on Cedar Magnet sound board (fake IRQ still necessary, but vectors are correct now).
<br>
 * Source note regarding IM 2 behavior contrary to Zilog datasheet.
<br>

<br>
-Corrected natural keyboard handling of toggle keys. [AJR]
<br>

<br>
-break86: Tried to make some sense of the DIP settings in the service manual [AJR]
<br>

<br>
-Service mode DIP switch adjustments: [AJR]
<br>
 * Use the default sequence for the non-toggle service mode/test switch for service mode DIP switch unless the machine has one of
<br>
    those as well.
<br>
 * Automatically define DIP and configuration switches as toggle fields (makes assigning input codes easier).
<br>

<br>
-Correctly report size of ROMs over 2GB in XML output. [AJR]
<br>

<br>
-Cedar Magnet/EFO ZSU improvements: [AJR]
<br>
 * Got rid of fake IRQ in Cedar Magnet sound system.
<br>
 * Converted the Cedar Magnet board from a base device class to a mix-in interface.
<br>
 * Emulated EFO ZSU as main variant of the Cedar Magnet sound board.
<br>
 * Hooked up ZSU1 to Skill Flight and Phantom Ship.
<br>
 * Modernized ZSU soundlatch/IRQ mechanism.
<br>

<br>
-More DAC identification and sound stuff. [AJR]
<br>
 * Legion and Rygar have YM3526 instead of YM3812 (other Nichibutsu games to be checked).
<br>
 * Identified DACs used in most Midway and Williams games.
<br>
 * Zektor uses an AY-3-8912, not 8910.
<br>
 * Corrected name of Turbo Cheap Squeak board.
<br>
 * Hyphenated title of F-14 Tomcat.
<br>
 * Corrected Color Computer DAC type and separated single-bit sound.
<br>

<br>
-polepos.cpp: Sound improvements for bootlegs [AJR]
<br>
 * Working Spanish/Italian voices in polepos2bi and polepos2bs.
<br>
 * DAC for passing car sound in topracern, polepos2bi and polepos2bs.
<br>
 * These bootlegs may still be missing explosion sounds.
<br>

<br>
-skyarmy: Various small improvements: [AJR]
<br>
 * Fixed screen flipping in cocktail mode.
<br>
 * Re-added second AY-3-8910A that generates explosion sounds.
<br>
 * Added coin counter.
<br>

<br>
-bagmanf: Fixed inputs and shuffled PROMs for better colors (game still tends to crash). [AJR]
<br>

<br>
-kangaroob: Added proper ROM labels and locations. [AJR]
<br>

<br>
-newbrain improvements: [Curt Coder]
<br>
 * Added character ROM and more accurate video output.
<br>
 * Fixed keyboard.
<br>
 * Decoded VFD bitstream, and added simultaneous video and VFD display.
<br>
 * Fixed CPU clocks and interrupt logic, added layout for VFD-less model, enforced power on reset timer.
<br>

<br>
cop400 improvements: [Curt Coder]
<br>
 * Fixed disassembly of jump instructions and used decimal for LDD/XAD.
<br>
 * Fixed instruction timing and time-base counter.
<br>
 * Fixed COP444 disassembly.
<br>
 * Properly separated COP444L from COP444C.
<br>

<br>
-advision: Fixed CPU clock; turtles music is now melodic. [Curt Coder]
<br>

<br>
-OS X Cocoa debugger: Autoscroll log window, improved view scoll behaviour. [Curt Coder]
<br>

<br>
-74153: Rewrote emulation, only output state when the level changes. [Dirk Best]
<br>

<br>
-apricot: Use 74153 for the serial clock selector. [Dirk Best]
<br>

<br>
-gen_latch updates:
<br>
 * Added MCFG_GENERIC_LATCH_DATA_PENDING_CB to raise and lower a line automatically as the latch is written and read. [AJR]
<br>
   - Makes sound IRQs easier to deliver and reduces the incidence of HOLD_LINE in drivers.
<br>
 * Inverted logic (latch_read -&gt; latch_written), fixed initial callback after start. [Dirk Best]
<br>

<br>
-ashnojoe, crospang, crshrace, dcheese: Latch cleanup. [Dirk Best]
<br>

<br>
-ddenlovr, expro02, f1gp feversoc, fuukifg2, gaelco: ACCESSING_BITS cleanup. [Dirk Best]
<br>

<br>
-z80ne: Killed direct update handler. [Dirk Best]
<br>

<br>
-chdman: Added support for hard disk templates and added some initial ones. [Dirk Best]
<br>

<br>
-Added A1200 keyboard skeleton device (needs MC68HC05Cx support). [Dirk Best]
<br>

<br>
-Added HLCD0515/0569 LCD Driver device. [hap]
<br>

<br>
-TMS0970: Fixed a problem with DDIG line, causing MB Comp IV to be unplayable. [hap]
<br>

<br>
-hh_tms1k: Fixed wrong button mapping for Codename Sector. [hap]
<br>

<br>
-VME bus improvements: [Joakim Larsson Edstrom]
<br>
 * Added new VME slave board: mzr8300.
<br>
 * Added device installers for A16:D8, A16:D16, A24:D8 and A24:D16.
<br>
 * mzr8300: hooked up the 7201 correctly and added RS232, now supporting the mzr8105 over VME bus as previously faked.
<br>
 * Converted mvme350 board driver to slot device.
<br>
 * Force Computers: Converted fcisio1 and fcscsi1 boards to slot devices and added VME interface to fccpu30.
<br>
 * Force Computers: Added VME interface to fccpu1, fccpu20 and hk68v10.
<br>
 * Added miniFORCE 2P21 chassis.
<br>
 * hd63450: Fixed device to find the owner CPU if the top node doesn't have a CPU, like in the case of a VME chassis.
<br>
 * fccpu20: Set terminal as default rs232 device, changed crystal value after visual verification to get 9600 Baud.
<br>
   - Terminal works but needs to be set to 7bit.
<br>
 * fccpu30: Improved documentation.
<br>
 * miniFORCE: Added address map info and feature list for three models.
<br>
 * fccpu20: Added PCB layout and hooked up the Rx part, terminal is working now.
<br>
 * Added fccpu20 to Miniforce as a VME card.
<br>
 * fccpu20: Moved all code and documentation to the slot device, promoted to working driver.
<br>

<br>
-Added MC68153 Bus Interrupter Module device. [Joakim Larsson Edstrom]
<br>

<br>
-MPCC improvements: [Joakim Larsson Edstrom]
<br>
 * Robustification, LOG messages and pinout added.
<br>
 * Completed Tx, Rx and serial interface handshake support.
<br>

<br>
-Added JuliaLang utf8proc as a third party library with wrappers. [Nathan Woods]
<br>

<br>
-imgtool improvements: [Nathan Woods]
<br>
 * Changed charconv from an enumeration to an interface:
<br>
   - Added a table-based implementation for simple single-byte endocdings.
<br>
   - Added support for ISO-8859-1 Latin 1 and Mac Roman.
<br>
 * Use wcout/wcerr in order to support Unicode console output.
<br>
 * Fixed recently introduce bug on attribute listings.
<br>
 * CoCo/RS-DOS: Miscellaneous cleanups and C++ modernization.
<br>

<br>
-CoCo: Fixed a recently introduced bug in DMK image creation. [Nathan Woods]
<br>

<br>
-Created a new debugger command 'tracesym': [Nathan Woods]
<br>
 * Shorthand for 'tracelog' that uses default format string.
<br>

<br>
-Added a facility allowing logerror output to be captured in traces. [Nathan Woods]
<br>
 * The third parameter to the debugger 'trace' is now a list of '|' delimited options to support this.
<br>

<br>
-Acorn Archimedes updates: [Nigel Barnes]
<br>
 * Added Diagnostic Test ROMs to aa310.
<br>
 * Renamed Archimedes 3000 -&gt; BBC A3000.
<br>
 * Single FDD installed by default, other bay usually contains HDD.
<br>
 * Removed tape control input port.
<br>
 * Added apd_dsk: new floppy format 'Archimedes Protected Disk'.
<br>

<br>
-mc68681: Added preliminary support for SC28C94 QUART, fixed channel C/D transmission. [R. Belmont]
<br>

<br>
-gba, vcs80: Removed deprecated direct update handlers. [R. Belmont]
<br>

<br>
-68230pit updates: [R. Belmont]
<br>
 * Don't forget all externally driven line states when the DDR changes.
<br>
 * Return proper port values when line states are pushed instead of pulled.
<br>

<br>
-Pyon Pyon Jump: Documented board 7908B pinout and #1/#2 DIP switches. [Roberto Fresca]
<br>

<br>
-Gran Premio F1 (Spanish bootleg of Pole Position II) updates: [Arcade Hacker, Rockman, Roberto Fresca]
<br>
 * Redumped some faulty devices (the former speech ROM has bit6 fixed).
<br>
 * Added proper bipolar PROMs dumps.
<br>
 * Documented 'A'/'B'/'C' board edge connectors.
<br>

<br>
-New driver for Mega Bonus Star II (Euro, Millennium Edition): [Roberto Fresca]
<br>
 * Derived machine and started a proper memory map, the game starts to show attract mode.
<br>
 * Changed the romset name according to the real game name.
<br>
 * Video hardware work to fix the video reels.
<br>
 * Inputs worked out from scratch.
<br>
 * Added references for Z86C15 MCU.
<br>

<br>
-Mega Bonus Star II (Euro, Millennium Edition) notes: [Roberto Fresca, Team Eurpoe]
<br>
 * Added more documentation, tech notes, and M48T12 timekeeeper dump for preservation and further analysis.
<br>

<br>
-Mega Bonus Star II (Euro, Millennium Edition): Added GAL dump. [Team Europe]
<br>
 * Added unknown Zilog DIP40 IC diagram, looks as a Z8 family MCU.
<br>

<br>
-Added decapped MCU dump for the original quizard. [TeamEurope]
<br>

<br>
-aristmk5: Added SPI and hopper emulation, allowing non-US games to boot. [Sandro Ronco]
<br>

<br>
-midzeus: Changed waveram viewer to use V key to fix conflict with game controls. [Ted Green]
<br>

<br>
-Added decapped dump of the d8751 on quizard4 sets (not hooked up yet). [Team Europe, David Haywood]
<br>
 * Also fixed fixed flags on quizard3 and 4 game versions that never worked past coin-up.
<br>

<br>
-Taito 68705 refactoring: [David Haywood]
<br>
 * Renamed the buggychl_mcu_device (machine/buggychl.cpp) to taito68705interface.cpp because a number of drivers used it.
<br>
 * Refactored that device to use the new 68705 core with built-in peripherals.
<br>
 * Refactored some other drivers, including tokio, daikaiju, flstory, lkage, nycaptor and lsasquad, to use it.
<br>
 * Moved 68705 timer logic out of arkanoid driver and into 68705 core.
<br>

<br>
-stv.cpp: Cleaned up comments, BAD_DUMP flags and set descriptions based on recent Print Club 2 set redumps, and added preconfigured
<br>
 NVRAM to non-corrupt set. [David Haywood]
<br>

<br>
-Added a preconfigured NVRAM to tangtang in esd16.cpp so it won't boot with invalid settings. [David Haywood]
<br>

<br>
-Added a dump of one of the HNG64 TMP87PH40AN I/O chips. [CAPS0ff]
<br>
 * This came from a sample OTP chip that was purchased for testing/analysis, not one of the chips actually taken from a HNG64 unit!
<br>
 * The chip had no protection and read out without issue.
<br>
 * It isn't clear if this is the driving, shooting or fighting MCU type.
<br>

<br>
-stuntcyc logic emulation: [Ryan Holtz]
<br>
 * Added netlist.
<br>
 * Fixed some NOR gates that should have been NANDs, fixes the playfield.
<br>

<br>
-netlist improvements: [Couriersud]
<br>
 * ROMs now specify an identifier in the netlist to load data from a source_t implementation.
<br>
 * Added &quot;-r&quot; option to nltool to pass path to a folder containing ROM files.
<br>
 * setup_t is owned by netlist_t; stop being complicated.
<br>
 * Removed gnd() method, simplified further.
<br>
 * Fixed seldom-used conditional build options including OPENMP.
<br>
 * Increased readability of timed queue code.
<br>
 * Reamed connect_late to connect.
<br>
 * Register nets where they are created.
<br>
 * Preparatory work for automatically generated include files for devices.
<br>
   - nltool now is able to create all defines from the factory definitions.
<br>
 * Added code to remove devices connected only to rail terminals.
<br>
 * Refactored reverse polish notation evaluator into own its source files.
<br>
 * Added function parameter to current and voltage sources VS and CS (e.g. to produce a sine wave).
<br>
 * Changed code to allow devices to optionally be treated as dynamic or timestepping devices.
<br>
 * Converted warnings and fatal log messages to constants.
<br>
 * Assume string literals are UTF8 in netlist code.
<br>

<br>
-mario: Hooked up Luigi walking sound in netlist sound implementation. [Couriersud]
<br>
 * Driver now uses netlist audio implementation instead of discrete implementation.
<br>
 * The previous emulation has not been removed yet because it still contains a lot of documentation.
<br>

<br>
-netlist: Added LM747, LM747A and 2N2565. [Vas Crabb]
<br>

<br>
-gsword.cpp updates: [Vas Crabb]
<br>
 * Split out gsword and josvolly functionality from base driver class.
<br>
 * Identified josvolly &quot;AA 007&quot; chip as NECD8255A for reading input ports as shown by CAPS0ff die shot.
<br>
 * Hooked up josvolly MCUs for communication between CPUs, improves test mode behaviour.
<br>
 * Added DIP locations to josvolly based on test mode.
<br>
 * Named unknown DIP settings after the location they control in main RAM.
<br>
 * Identified josvolly cabinet type DIP switch.
<br>
 * Removed obsolete josvolly MCU simulation.
<br>

<br>
-gladiatr.cpp improvements: [Vas Crabb]
<br>
 * Separated gladiatr and ppking state classes.
<br>
 * Hooked up all four MCUs in gladiatr sets, games now honour coinage settings.
<br>
 * Eliminated tagmap lookups on input read.
<br>
 * Add bootleg MCU dumps to all gladiatr sets as BAD_DUMP, removed MCU simulation, and updated notes.
<br>

<br>
-m6805: refactoring and improvements [Vas Crabb]
<br>
 * Moved 68705 devices into their own file, Made P3, P5, R3 and U3 variants and made them load bootstrap ROMs.
<br>
 * MC68705R3 bootstrap ROM is believed to be identical to U3, but a dump is required for confirmation.
<br>
 * Implemented EPROM control (saves contents using NVRAM mechanism).
<br>
 * Implemented differences for open drain I/O ports.
<br>
 * Re-implemented timer/counter - supports MOR-controlled mode, correct count direction, and correct start/reset states.
<br>
 * Fixed state of input lines being lost on reset.
<br>
 * Use symbolic names for I/O registers in disassembly.
<br>
 * Exposed more more internal registers through the state interface - shows contents of registers that can't be read as memory.
<br>
 * Reduced massive amounts of redundancy by templating opcode handlers and replaced the epic switch statement with a dispatch table.
<br>
 * Turned a lot of macros into inline methods so they can be scoped down.
<br>
 * Fixed timings for a few instructions and added a table with CMOS instruction timings.
<br>
 * Corrected affected flags in comments on opcode handlers (actual code was correct).
<br>
 * Removed unnecessary flag calculation tables.
<br>
 * Added compile-time configurable logging for onboard MC68705 peripherals to help debug issues.
<br>
 * Completely eliminated the concrete 68705-without-peripherals class.
<br>
 * Use MC68705P3 core for bub68705, changela, maxaflex, mexico86, qix.cpp, taitosj.cpp and tstrike/ddungeon/darktowr, simulate
<br>
    synchronous latches better.
<br>
 * Use MC68705R3 core for pipeline.
<br>
 * Use MC68705P5 core for pitnrun.
<br>
 * Use MC68705P5 core for quizpun, MCU now gets timer interrupts correctly (still not working).
<br>

<br>
-taito68705interface improvements: [Vas Crabb]
<br>
 * Added abstract base class with latch logic written for arkanoid/puzznic.
<br>
 * Removed non-obvious mcu_status_r and semaphore_r members and moved to drivers (varies by system).
<br>
 * Got rid of the unnecessary hacks for bigevglf, it doesn't need anything special.
<br>
 * Folded Slap Fight functionality into common device class.
<br>
 * Used common device for maniach, maniach2, renegade, retofinv and xsleena.
<br>
 * Added device for arkanoid/puzznic MCU setup, replacing glue in arkanoid and simulation in puzznic.
<br>
 * Removed leftover crud from driver state classes.
<br>

<br>
-hotsmash, pbillian: Cleanup: [Vas Crabb]
<br>
 * Did bare minimum work to extricate hotsmash/pbillian from superqix_state.
<br>
 * Migrated to M68705P5 core instead of in-driver peripherals.
<br>
 * Reduced tagmap lookups.
<br>

<br>
-stfight.cpp: Fixed ADPCM control. [Vas Crabb]
<br>
 * Used MC68705P5 core rather than in-driver peripherals.
<br>
 * Latch ADPCM counter on the correct edge.
<br>
 * Remove unused members, eliminate function statics, and fix up save state registration.
<br>
 * Reduced runtime tagmap lookups.
<br>

<br>
-tigeroad.cpp: Cleanup and modernisation: [Vas Crabb]
<br>
 * Split out bballs and pushman state classes.
<br>
 * Used new MC68705R3 core for pushman, make communication with host CPU believable.
<br>
 * Used derived memory maps rather than installing handlers in init members.
<br>
 * Simplified bballs protection MCU simulation using pushman hookup as a guide.
<br>

<br>
-a2bus/mouse.cpp: Simplification and cleanup: [Vas Crabb]
<br>
 * Used new MC68705P3 core and removed obsolete glue.
<br>
 * Made comment styles consistent, eliminated device timers altogether, and de-duplicated code for updating X and Y axes.
<br>
 * The card works before and after the change, but by default axes are only mapped to inc/dec keys, not host mouse.
<br>

<br>
-taito_l.cpp: Split giant state class up into family tree, reduced tagmap lookups. [Vas Crabb]
<br>

<br>
-i8251: Made receive more reliable, cleaned up a little. [Vas Crabb]
<br>

<br>
-zorba improvements: [Vas Crabb]
<br>
 * Created emulated keyboard device using MC68705P3 core.
<br>
   - Identified 88 of 96 matrix keys, 6 of 8 DIP switches, and 3 of 6 outputs.
<br>
 * Connected IEEE-488, RS232 and Centronics ports.
<br>
 * Hooked up all IRQ sources and connected PIT to USARTs.
<br>

<br>
-m6805evs: Added proper memory map in comment and note that it needs CPU core support for the 68HC705 family. [Vas Crabb]
<br>

<br>
-Added logmacro.h inspired by Edstrom's log macros. [Vas Crabb]
<br>
 * Should be #included after other headers and after optionally #defining VERBOSE, usage samples in z80scc.cpp and m68705.cpp.
<br>

<br>
-arkanoid: Confirmed MCU reset also resets semaphore flags. [Lord Nightmare, Vas Crabb]
<br>

<br>
-debugger: Use 0o prefix for octal numbers, 0b for binary numbers, and allow uppercase radix characters. [shattered, Vas Crabb]
<br>

<br>
-superqix.cpp: Deprotected an original Japan/World Super Qix 8751 MCU, and verified that the presumed B03 // 03 MCU dump is correct.
<br>
 [Lord Nightmare]
<br>

<br>
-arkanoid.cpp: Fixed watchdog to match PCB tracing and update some comments. [Lord Nightmare]
<br>

<br>
-Zorba keyboard: Fixed F4 in natural keyboard mode. [Robbbert]
<br>

<br>
-Enabled rm380z34d and rm380z34e. [Robbbert]
<br>

<br>
-Added support for earlier COS versions on the RM380Z. [zx70]
<br>
 * Earlier versions had only a 40 column display and the cassette tape interface.
<br>

<br>
-Made the RTC chip react on the Aussie Byte. [zx70]
<br>

<br>
-Scrollup fix for the TMS9927 family. [zx70]
<br>
 * Avoid reconfiguring all the CRTC parameters on any cursor shape change, which was resetting the scroll counter.
<br>
 * Fixes scrollup for the Otrona Attache.
<br>

<br>
-pc_dsk: Support 360K images with 512-byte header, found in some softlist entries. [Justin Kerk]
<br>
 * Also support 1.44MB images with 1024-byte footer.
<br>

<br>
-pc_dsk: Assume a smaller gap size to allow 400K disk images to load. [Justin Kerk]
<br>
 * Fixes e.g. ikari and marble from the ibm5150 softlist.
<br>

<br>
-tandy1t: Distinguish between models using 90-key Tandy and standard 101-key &quot;Enhanced&quot; AT keyboard layouts. [Justin Kerk]
<br>
 * Also unmapped Hold key on the 90-key layout by default to avoid freezing the emulated system when switching UI modes.
<br>

<br>
-atvtrack improvements - game code running now as it should: [MetalliC]
<br>
 * Extracted CPU initial boot from FPGA bitsream.
<br>
 * Implemented NAND Flash erase and program commands.
<br>
 * Hooked GPU IRQs control.
<br>
 * Added basic simulation of GPU's internal CPU for game init speedup.
<br>
 * Documented IO-port multiplexing.
<br>

<br>
-naomi docs update: [MetalliC]
<br>
 * Dead or Alive 2 Millenium now parent of DoA2 set.
<br>
 * Renamed Star Horse sets for consistency.
<br>

<br>
-Researched and documented NAOMI ROM board type 171-7885A master/slave features. [rtw, MetalliC]
<br>

<br>
-IBM 6580 Displaywriter de-skeletonization. [shattered]
<br>

<br>
-i8255: In read_pc(), also return data from output latch. [shattered]
<br>

<br>
-ImageDisk loader: Don't crash on tracks with no data. [shattered]
<br>

<br>
-TeleDisk loader: Accept images produced from 8&quot; SSSD disks. [shattered]
<br>

<br>
-imagedev/floppy: Added 'dskchg_writable' property (for Sony Microfloppy drives). [shattered]
<br>

<br>
-imagedev/floppy: Added has_trk00 property, initially for IBM 6360 8-inch drives. [shattered]
<br>

<br>
-imagedev/floppy: Inhibit reading until drive has spun up. [Michael Zapf]
<br>
 * This affects drives/controllers that do not use the READY line.
<br>
 * Still an over-simplified solution; requires a proper implementation of a spin-up ramp.
<br>
 * Stepping is allowed during spin-up until further evidence from real drives.
<br>

<br>
-formats/wd177x_dsk: Allow override of build_sector_description, like nec765_dsk. [shattered]
<br>

<br>
-polyplay: Added a German version of ZRE-PP based polyplay and a Czech ROM. [SailorSat]
<br>
 * Modernized/devicified the polyplay driver.
<br>
 * Documented differences in hardware.
<br>
 * Added newer ZRE-PP board (SIO not yet hooked up).
<br>
 * Added a Czech export version with the new menu.
<br>
 * Fixed undocumented Z80 CTC 'on-the-fly' mode switch; internal timer didn't stop.
<br>
 * Added new polyplay2 romset; german version with 10 games (6 new ones).
<br>
 * Renamed Czech version to polyplay2c and made a clone of polyplay2.
<br>

<br>
-harddriv: Hooked up the first serial port as an RS232 device to enable linking. [SailorSat]
<br>
 * This allows one to link up two Race Drivin' using null-modem and bitbanger (38400 8E1).
<br>

<br>
-HP9895 dual-floppy drive WIP: [F.Ulivi]
<br>
 * Added draft of HP9895 floppy drive, PHI passes POST.
<br>
 * 9895 now talks through ieee488!
<br>
 * Cosmetic fixes to 9895-related source files.
<br>

<br>
-gaelco: Dumped &quot;Biomechanical Toy (Ver. 1.0.1884)&quot; sound roms, fixes audio in this version. [ShouTime]
<br>

<br>
-Verified that Plump Pop uses the same M-Chip as extermination and Dr. Toppel; added and corrected labels, locations and chip types
<br>
 for several ROMs/PROMs as well as updated notes, based on PCB pictures. [ShouTime]
<br>

<br>
-segae.cpp: Fixed incorrect Opa Opa ROM labels. [ShouTime]
<br>

<br>
-Updated PortAudio library and added audio output module. [inte alls]
<br>
 * Provides low-latency audio output on Windows 7 or later and Linux.
<br>

<br>
-ppcdrc.cpp: Clear two LSBs of the branch target address. [maximumspatium]
<br>
 * Fixes an issue preventing Power Macintosh 6100 from starting up.
<br>

<br>
-x1.cpp: Added kana input support. [r09]
<br>
 * Added all kana and kana+shift key combinations.
<br>
 * Changed the kana key into a toggle, like in real hardware.
<br>
 * Added some missing keys that exist on the actual X1 keyboard.
<br>

<br>
-taito_f3: Fixed missing graphics on state load. [moralrecordings]
<br>

<br>
-Added write line member for terminal count line of upd765. [Patrick Mackinlay]
<br>

<br>
-retofinv.cpp: Added comment about developer (thanks to TCRF and GDRI). [Stiletto]
<br>

<br>
-Added the Sonic 3 proto lock-on chips to the relevant Sonic 3 proto sets. [einstein95]
<br>

<br>
-cvs.cpp: Only show popmessage on unknown writes if VERBOSE is defined. [system11]
<br>

<br>
-a78_slot: Fixed broken 144k + POKEY@450 emulation. [Mike Saarna, trebor]
<br>
 * Bentley Bear's Crystal Quest and Donkey Kong PK-XM no longer crash.
<br>

<br>
-DEC Rainbow 100 updates: [Bavarese]
<br>
 * Enabled Corvus hard drives (Patched CP/M 1.x only, requires DRCDUTIL.TD0 driver disk from Maslin archive).
<br>
   - See section CORVUS HARD DISK for patch instructions.
<br>
   - DOS 2.x and CP/M 2.2 were once supported too, but drivers appear to be lost.
<br>
 * Added info about 6 and 20 MB Corvus drives and how to format/use them under CP/M 1.x.
<br>

<br>
-aztarac.cpp: Verified and corrected labels/locations and added newly dumped video board PROMS. [Andrew Welburn, Tafoid]
<br>

<br>
-ms32.cpp: Corrected ROM names for Best Bout Boxing. [Corrado Tomaselli, The Dumping Union]
<br>

<br>
-pse.cpp: Redumped bazookabr. [f205v]
<br>

<br>
-Corrected tilemap colors in Stadium Hero. [Bryan McPhail, Guru]
<br>

<br>
-armedf.cpp: Verified and corrected clocks for Sky Robo / Tatakae! Big Fighter. [Guru]
<br>

<br>
-hng64: Documented I/O CPU clock. [Guru]
<br>

<br>
-pacman.cpp: Added readme for Number Crash. [Guru]
<br>

<br>
-jollyjgr.cpp: Updated readme and corrected clocks for Jolly Jogger. [Guru]
<br>

<br>
-hiscore.dat: Updates [Leezer]
<br>

<br>
-Added handy ROM filename discrepancy spotter scripts. [Zoe Blade]
<br>
 * Identifies identical ROMs that have different names in parent and clone sets.
<br>

<br>
-Updated V.Smile software list: [Fake Shemp]
<br>
 * Split into three lists: regular V.Smile, V.Smile Motion, and V.Smile Baby (Motion and Baby lists not hooked up yet).
<br>
 * Updated with a bunch of new-found carts and been restructured to indicate which carts are undumped.
<br>
 * Documented cart internals more thoroughly - descriptions now list PCB types, chip placements/labels, etc. if available.
<br>
 * Added previously missed dumps, fixed some typos.
<br>

<br>
-Added more software list documentation based off new dumps. [Fake Shemp]
<br>
 * Carts for a2600, megadriv, n64 and snes got redumped recently by TeamEurope; added newfound information to the softlists.
<br>
 * Removed syvalionp2 as it's simply a bad dump of syvalionp.
<br>

<br>
-pc.cpp updates: [rfka01]
<br>
 * Added Atari PC1 and corrected name of Atari PC3.
<br>
 * Gave standard pccga five slots, so machines with combo cards can have hard disks as well until combo cards are emulated.
<br>
 * Reordered MCFG and ROM entries to match the machine list at the bottom of the file.
<br>
 * Derived NCR PC4i configuration from VGA PC and corrected number of slots.
<br>
 * Made 720K drives standard for laptops which have them.
<br>
 * Added info on Zenith Supersport, Bondwell Pro28, and Atari PCs.
<br>
 * Added info on several already emulated systems in the header.
<br>
 * Added detailed information on Data General One, Commodore PC-1, Commodere PC10-III and PC20-III, Zenith SuperSport,
<br>
    Siemens Sicomp PC16-05, NCR PC4i, Olivetti M15, Sharp PC-7000, Sanyo MBC-16, Atari PC-3, Eagle 1600, VTech Laser Turbo XT
<br>
    and XT/3.</div>
<br>

<br>
Related links:
<br>
[ <a href="http://www.aep-emu.de/emus13.html" target="_blank" class="postlink">Arcade Multi Emulatoren</a> ][ <a href="http://www.aep-emu.de/emus67.html" target="_blank" class="postlink">Arcade Single Emulatoren</a> ]</td>
        </tr>
        <tr>
          <td height="40" valign="bottom" class="genmed">
          <!-- Begin PNphpBB2 Attachment Mod -->
            
          <!-- End PNphpBB2 Attachment Mod -->
            <div class="postbody">&nbsp;</div>
            <span class="gensmall">&nbsp;</span>
          </td>
        </tr>
        <tr>
	        <td class="gensmall" align="right">  &nbsp;</td>
	      </tr>
      </table>
    </td>
  </tr>
  <tr>
    <td valign="bottom" nowrap="nowrap" class="row1">
      <div class="gensmall" style="float:left">&nbsp;<a href="PNphpBB2-file-profile-mode-viewprofile-u-1481.html?sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/icon_profile.gif" width="59" height="18" alt="View user's profile" title="View user's profile"></a> <a href="PNphpBB2-file-privmsg-mode-post-u-1481.html?sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/icon_pm.gif" width="59" height="18" alt="Send private message" title="Send private message"></a>      &nbsp;</div>
      <div class="gensmall" style="float:right"><a href="index.php?name=PNphpBB2&amp;file=posting&amp;mode=quote&amp;p=98124&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/icon_quote.gif" width="59" height="18" alt="Reply with quote" title="Reply with quote"></a>  <a href="#top"><img src="modules/PNphpBB2/templates/PNTheme/images/icon_up.gif" width="16" height="18" alt="Back to top" title="Back to top"></a></div>
    </td>
  </tr>

  <tr>
    <td colspan="2" height="1"><img src="./modules/PNphpBB2/templates/PNTheme/images/spacer.gif" alt="" width="1" height="1"></td>
  </tr>
  
  <tr>
    <td class="cat" colspan="2" height="28">
      <table cellspacing="0" cellpadding="2" border="0" align="center">
        <tr>
          <td>
            <form method="post" action="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;start=0&amp;sid=192a599b7d6186efa01db38b4ff0cab7">
            <table cellspacing="0" cellpadding="0" border="0" align="center">
	            <tr align="center">
		            <td nowrap="nowrap">
                  Display posts from previous:&nbsp;&nbsp;<select name="postdays"><option value="0" selected="selected">All Posts</option><option value="1">1 Day</option><option value="7">7 Days</option><option value="14">2 Weeks</option><option value="30">1 Month</option><option value="90">3 Months</option><option value="180">6 Months</option><option value="364">1 Year</option></select>&nbsp;<select name="postorder"><option value="asc" selected="selected">Oldest First</option><option value="desc">Newest First</option></select>&nbsp;&nbsp;
                  <input type="submit" value="Go" class="catbutton" name="submit">
                </td>
              </tr>
            </table>
            </form>
          </td>
        </tr>
        <tr align="center">
          <td><form method="post" name="jumpbox" action="index.php?name=PNphpBB2&amp;file=viewforum&amp;sid=192a599b7d6186efa01db38b4ff0cab7" onSubmit="if(document.jumpbox.f.value == -1){return false;}">
<table cellspacing="0" cellpadding="0" border="0" align="center">
	<tr align="center">
		<td nowrap="nowrap">
			<span class="gensmall">Jump to:&nbsp;<select name="f" onchange="if(this.options[this.selectedIndex].value != -1){ forms['jumpbox'].submit() }"><option value="-1">Select a forum</option><option value="-1">&nbsp;</option><option value="-1">Forum index</option><option value="-1">|--[Emu News]</option><option value="8"selected="selected">|&nbsp;&nbsp;&nbsp;|--&nbsp;News</option><option value="-1">|--[Emulation]</option><option value="4">|&nbsp;&nbsp;&nbsp;|--&nbsp;Allgemein / General</option><option value="15">|&nbsp;&nbsp;&nbsp;|--&nbsp;Emulatoren für Arcade und NeoGeo</option><option value="11">|&nbsp;&nbsp;&nbsp;|--&nbsp;Emulatoren für Retro-Systeme</option><option value="12">|&nbsp;&nbsp;&nbsp;|--&nbsp;Emulatoren für Handheld-System</option><option value="13">|&nbsp;&nbsp;&nbsp;|--&nbsp;Emulatoren für neuere Konsolen</option><option value="14">|&nbsp;&nbsp;&nbsp;|--&nbsp;Emulatoren für NextGen Systeme</option><option value="21">|&nbsp;&nbsp;&nbsp;|--&nbsp;Tutorials und FAQs</option><option value="5">|&nbsp;&nbsp;&nbsp;|--&nbsp;Trash</option><option value="-1">|--[AEP Projekte]</option><option value="6">|&nbsp;&nbsp;&nbsp;|--&nbsp;AEP Emulation Page</option><option value="3">|&nbsp;&nbsp;&nbsp;|--&nbsp;CVS Compile</option><option value="-1">|--[Sonstiges]</option><option value="10">|&nbsp;&nbsp;&nbsp;|--&nbsp;Quiz Shows</option><option value="22">|&nbsp;&nbsp;&nbsp;|--&nbsp;Highscore Competitions</option><option value="20">|&nbsp;&nbsp;&nbsp;|--&nbsp;Games und Konsolen</option><option value="17">|&nbsp;&nbsp;&nbsp;|--&nbsp;Computer und Betriebssysteme</option><option value="16">|&nbsp;&nbsp;&nbsp;|--&nbsp;Musik und Film</option><option value="1">|&nbsp;&nbsp;&nbsp;|--&nbsp;OffTopic</option><option value="23">|&nbsp;&nbsp;&nbsp;|--&nbsp;It's-a Me</option></select><input type="hidden" name="sid" value="192a599b7d6186efa01db38b4ff0cab7"><input type="hidden" name="op" value="modload"><input type="hidden" name="name" value=PNphpBB2><input type="hidden" name="file" value="viewforum"><input type="hidden" name="sid" value="sid=192a599b7d6186efa01db38b4ff0cab7">&nbsp;
		        <input type="submit" value="Go" class="liteoption">
			</span>
    		</td>
	</tr>
</table>
</form>

</td>
        </tr>
      </table>
    </td>
  </tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr>
    <td colspan="3" align="right" valign="top">
      <div class="gensmall">All times are GMT + 1 Hour</div>
    </td>
  </tr>
  <tr>
    <td align="left" nowrap="nowrap">
      <a href="index.php?name=PNphpBB2&amp;file=posting&amp;mode=newtopic&amp;f=8&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/post.gif" width="82" height="25" alt="Post new topic" title="Post new topic"></a>&nbsp;&nbsp;&nbsp;<a href="index.php?name=PNphpBB2&amp;file=posting&amp;mode=reply&amp;t=21790&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/lang_english/reply.gif" width="82" height="25" alt="Reply to topic" title="Reply to topic"></a>
    </td>
    <td colspan="2" nowrap="nowrap"><table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=previous&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_previous.gif" width="15" height="25" alt="View previous topic" title="View previous topic" border="0"></a></td>
<td></td>
<td><a href="index.php?name=PNphpBB2&amp;file=printview&amp;t=21790&amp;start=0&amp;sid=192a599b7d6186efa01db38b4ff0cab7" target="_blank"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_print.gif" width="24" height="25" border="0" alt="Printable version" title="Printable version"></a></td>
<td></td>
<td><a href="index.php?name=PNphpBB2&amp;file=privmsg&amp;folder=inbox&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/pm_no_new.gif" width="24" height="25" border="0" alt="Log in to check your private messages" title="Log in to check your private messages"></a></td>
<td><a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=next&amp;sid=192a599b7d6186efa01db38b4ff0cab7"><img src="modules/PNphpBB2/templates/PNTheme/images/topic_next.gif" width="14" height="25" alt="View next topic" title="View next topic" border="0"></a></td>
</tr>
</table>

</td>
  </tr>
  <tr>
    <td class="nav" valign="top"></td>
    <td rowspan="2" align="right" valign="top"></td>
  </tr>
  <tr>
    <td class="nav" width="100%">
      &nbsp;<a href="index.php?name=PNphpBB2&amp;file=index&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">AEP Emulation Page - Emulation News Forum Index</a>&nbsp;&raquo;&nbsp;<a href="index.php?name=PNphpBB2&amp;file=index&amp;c=3&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">Emu News</a>&nbsp;&raquo;&nbsp;
      <a href="index.php?name=PNphpBB2&amp;file=viewforum&amp;f=8&amp;sid=192a599b7d6186efa01db38b4ff0cab7" class="nav">News</a>
    </td>
  </tr>
</table>
<table width="100%" border="0" cellspacing="0" cellpadding="2">
  <tr>
    <td class="gensmall" align="right" valign="top">
      <!-- <strong></strong><br>
<br>
<a href="index.php?name=PNphpBB2&amp;file=printview&amp;t=21790&amp;start=0&amp;sid=192a599b7d6186efa01db38b4ff0cab7" target="_blank" title="Printable version">Printable version</a><br>
<a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=previous&amp;sid=192a599b7d6186efa01db38b4ff0cab7">View previous topic</a><br>
<a href="index.php?name=PNphpBB2&amp;file=viewtopic&amp;t=21790&amp;view=next&amp;sid=192a599b7d6186efa01db38b4ff0cab7">View next topic</a><br>
-->
      <!-- You <b>cannot</b> post new topics in this forum<br>You <b>cannot</b> reply to topics in this forum<br>You <b>cannot</b> edit your posts in this forum<br>You <b>cannot</b> delete your posts in this forum<br>You <b>cannot</b> vote in polls in this forum<br>You <b>cannot</b> attach files in this forum<br>You <b>can</b> download files in this forum<br> -->
    </td>
  </tr>
</table>

<table width="100%" cellpadding="3" cellspacing="1" border="0">
<tr>
<td align="center" class="gensmall" style="text-align:center">Powered by <a style="text-decoration:none;" href="http://sourceforge.net/projects/pnphpbb2" target="_blank"><font color="ff6600"><b><i>PN</i></b></font><font color="0001f0"><b>phpBB2</b></font></a>&nbsp;&copy; 2003-2007&nbsp;The PNphpBB Group<br><a href="modules/PNphpBB2/docs/copyrite.html" onclick="window.open('modules/PNphpBB2/docs/copyrite.html', '_pnphpbb2_credits', 'HEIGHT=250,WIDTH=450,scrollbars=yes');return false;" target="_pnphpbb2_credits">Credits</a> </td>
</tr>
</table>

<a name="bot" id="bot"></a>
					</td>
				</tr>
			</table>
		</td>
	</tr>
</table>


</td></tr>
<tr align="center">
<td width="100%" colspan="3">
<div class="pn-sub"><a href="http://validator.w3.org/check?uri=referer" target="_blank"><img src="images/powered/valid-html401.png" alt="Valid HTML 4.01!" title="Valid HTML 4.01!" height="31" width="88" hspace="10"></a>
<a href="http://validator.w3.org/feed/check.cgi?url=http://www.aep-emu.de/rss_en.xml"><img src="images/powered/valid-rss.png" alt="[Valid RSS]" title="Validate my RSS feed" width="88" height="31" hspace="10"></a><br>
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest &copy; 1998 - 2016 <a href="http://www.aep-emu.de/">AEP Emulation Page</a>.

<br>You can syndicate our news via RSS using the file <a href="rss_en.xml">rss_en.xml</a> for English headlines and <a href="rss_de.xml">rss_de.xml</a> for German headlines.<br></div></td>
</tr>
</table>
<script type="text/javascript" src="js/lightbox.js"></script><script type="text/javascript" src="js/preview.js"></script>
<!-- Piwik --> 
<script type="text/javascript">
var pkBaseURL = (("https:" == document.location.protocol) ? "https://www.aep-emu.de/piwik/" : "http://www.aep-emu.de/piwik/");
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
</script><script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script><noscript><p><img src="/piwik/piwik.php?idsite=1" style="border:0" alt="Piwik"></p></noscript>
<!-- End Piwik Tracking Code -->

</body>
</html>